博尔指标文华版

作者: 飞橙 分类: 量化交易 发布时间: 2013-01-19 16:16 ė 351,579 浏览数 6 没有评论

//名称:博尔指标
//作者:bscorpio@文峰期货无锡部
//时间:2013.1.19
//说明:建议使用日线周期,从多头角度分析市场,多用于股票

//算法
MyClose := (HIGH + LOW + OPEN + CLOSE * 2) / 5;
Sell95: HHV(MyClose + H – L, 5), COLORGREEN;
Sell68: HHV(MyClose * 2 – L, 5), COLORCYAN;
LowLine: LLV(MyClose, 3), COLORYELLOW;
Buy68: LLV(MyClose * 2 – H, 8), COLORMAGENTA;
Buy95: LLV(MyClose – H + L, 8), COLORRED;

//画线
F := 100 * (C-REF(C, 1)) / REF(C, 1);
P1 := IF(C < REF(O, 1) AND F < 0, 1, 0);
P2 := IF(C < REF(O, 2) AND F < 0, 1, 0);
STICKLINE(P1 = 0 AND REF(P1, 1) = 1 AND P2 = 0 AND REF(P2, 1) = 1, OPEN, CLOSE, COLORMAGENTA, 0);
STICKLINE(P1 = 1 AND REF(P1, 1) = 0 AND P2 = 1 AND REF(P2, 1) = 0, OPEN, CLOSE, COLORBLUE, 0);

本文出自乐谷吧,转载时请注明出处及相应链接。

本文永久链接: http://www.legu8.com/?p=260

发表评论

邮箱地址不会被公开。 必填项已用*标注

Ɣ回顶部