MACD背离的指标公式

作者: 飞橙 分类: 量化交易 发布时间: 2015-08-30 21:45 ė 3,526 浏览数 6 没有评论

在茫茫股海中,将符合条件的股票选出来不是一件容易的事情,最近一直在研究这方面的东西,有些心得和大家分享下。内核为通达信的系列软件的功能都差不多,软件有两个重要的功能,能帮助解决手工选股的问题,一是指标排序,二是预警系统。大家多琢磨一下。

咱回到正题,下面的这个指标,MACD背离,主要用于股票择时。使用时可以把B1和B2的数值显示出来,作为股票排序或者预警的条件。指标的内容如下:

{MACD指标}
MYDIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORWHITE;
MYDEA:EMA(MYDIF,9),COLORYELLOW;
MYMACD:(MYDIF-MYDEA)*2,COLORBLUE,LINETHICK2;
MYEMACD:EMA(MYDIF-MYDEA,2),COLORSTICK;

{底背离}
A1:=BARSLAST(REF(CROSS(MYDIF,MYDEA),1));
B1:=REF(CLOSE,A1+1)>CLOSE AND MYDIF>REF(MYDIF,A1+1) AND CROSS(MYDIF,MYDEA);
DRAWLINE(A1=0,MYDEA,B1,MYDEA,0),COLORMAGENTA,LINETHICK2;
STICKLINE(B1,0,0.06,6,0),COLORMAGENTA;
DRAWTEXT(B1,0.12,’ 底背离’),COLORMAGENTA;

{顶背离}
A2:=BARSLAST(REF(CROSS(MYDEA,MYDIF),1));
B2:=REF(CLOSE,A2+1)<CLOSE AND REF(MYDIF,A2+1)>MYDIF AND CROSS(MYDEA,MYDIF);
DRAWLINE(A2=0,MYDEA,B2,MYDEA,0),COLORCYAN,LINETHICK2;
STICKLINE(B2,0,0.06,6,0),COLORCYAN;
DRAWTEXT(B2,0.12,’ 顶背离’),COLORCYAN;

本文出自乐谷吧,转载时请注明出处及相应链接。

本文永久链接: http://www.legu8.com/?p=900

发表评论

邮箱地址不会被公开。 必填项已用*标注

Ɣ回顶部